Knowledge Base

Products Impacted by the Log4Shell Vulnerabilities CVE-2021-44228, CVE-2021-45105, and CVE-2021-45046

KB1283 - Dec 23, 2021

Type: Troubleshooting

Description: Know which Sentry Software's products are impacted by the Log4Shell Vulnerabilities CVE-2021-44228, CVE-2021-45105, and CVE-2021-45046 and how to apply the security patches available.

Additional Keywords: Apache, log4j, Log4Shell, Security Patches, Vulnerabilities

Problem

The Log4Shell vulnerabilities CVE-2021-44228, CVE-2021-45105, and CVE-2021-45046 impact:

and more especially the troubleshooting tool silicium-launcher-tool.jar which is automatically installed along with these products.

Solution

Install:

These versions come with Apache log4j v2.17.0.